Building project - Eclipse

Sebastian Huber sebastian.huber at embedded-brains.de
Wed Mar 14 07:48:16 CDT 2012


On 03/14/2012 01:35 PM, Binkowski, Cassio wrote:
> On Wed, Mar 14, 2012 at 4:36 AM, Sebastian Huber
> <sebastian.huber at embedded-brains.de
> <mailto:sebastian.huber at embedded-brains.de>> wrote:
>
>     On 03/13/2012 11:11 PM, Binkowski, Cassio wrote:
>
>         On Tue, Mar 13, 2012 at 5:53 PM, Binkowski, Cassio <cassioiks at gmail.com
>         <mailto:cassioiks at gmail.com>
>         <mailto:cassioiks at gmail.com <mailto:cassioiks at gmail.com>>> wrote:
>
>             On Tue, Mar 13, 2012 at 5:28 PM, Sebastian Huber
>         <sebastian.huber at embedded-__brains.de
>         <mailto:sebastian.huber at embedded-brains.de>
>         <mailto:sebastian.huber at __embedded-brains.de
>         <mailto:sebastian.huber at embedded-brains.de>>> wrote:
>
>                 On 13/03/12 19:00, Binkowski, Cassio wrote:
>
>                     On Tue, Mar 13, 2012 at 11:10 AM, Sebastian Huber<
>         sebastian.huber at embedded-____brains.de
>         <mailto:sebastian.huber at embedded-__brains.de>
>         <mailto:sebastian.huber at __embedded-brains.de
>         <mailto:sebastian.huber at embedded-brains.de>>>  wrote:
>
>
>                         On 03/13/2012 05:07 PM, Binkowski, Cassio wrote:
>
>                                 What is the build directory name?
>
>
>                             It is actually build.
>                             /home/rtems/build
>
>                         The prefix must not be a subdirectory of the build
>         directory.
>
>                     I don't understand. Can you then point me the direction?
>
>                     Thanks
>
>
>                 In another mail you write this:
>
>
>                 ~/rtems-4.11-work/rtems/____configure --target=sparc-rtems4.11
>                 --disable-posix
>                 --disable-networking --disable-cxx --enable-rtemsbsp=sis
>                 --enable-tests=samples
>         --prefix=/home/rtems/build/____sparc-rtems4.11/sis
>
>
>                 In another mail you write this:
>
>
>                 It is actually build.
>                 /home/rtems/build
>
>
>             Ok. It is correct.
>
>
>                 => your prefix is a subdirectory of the build tree
>
>                 This makes no sense and is wrong.  Why not simply use the
>         default prefix?
>
>
>             But the default prefix Joel Sherril provided is the one that is
>         pointing
>             the the /sparc-rtems4.11/sis
>
>             What do you have for default?
>
>             /home/rtems/bild is where I have all things buit on.
>
>
>         I have configured it with prefix=/opt/rtems-4.11, still getting errors
>         in Eclipse.
>
>
>     Quite frankly, you are so sparse with information, who should I know what
>     "I have configured" is in your case?
>
>
>
>         Just for clarification:
>
>         Tools path: /opt/rtems-4.11
>         Source path: /home/rtems/rtems-4.11-work/__rtems
>         Build path: /home/rtems/build
>
>         Can you please advise?
>
>
>     cd
>     rm -rf build
>     mkdir build
>     cd build
>     /home/rtems/rtems-4.11-work/__rtems/configure --target=sparc-rtems4.11
>     --prefix=/opt/rtems-4.11 --disable-posix --disable-cxx
>     --enable-rtemsbsp=sis --enable-tests=samples --disable-networking
>     make
>     make install
>
>     If you get errors in this procedure fix them first.  You need an installed
>     BSP before you start with Eclipse!
>
>
> When I "make install", in the last lines, I get that it entered a few
> directories but there was nothing to do there.
> Is this a bad sign?

It might help to post these last lines.

I case the above steps were successful, you should have something like this

find /opt/rtems-4.11/sparc-rtems4.11/sis/
/opt/rtems-4.11/sparc-rtems4.11/sis/
/opt/rtems-4.11/sparc-rtems4.11/sis/lib
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/no-dpmem.rel
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/nfs.rel
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/rpcio.rel
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/libz.a
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/no-mp.rel
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/libsapi.a
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/librtemsbsp.a
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/linkcmds
[...]
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/bsp_specs
/opt/rtems-4.11/sparc-rtems4.11/sis/lib/no-io.rel
/opt/rtems-4.11/sparc-rtems4.11/sis/tests
/opt/rtems-4.11/sparc-rtems4.11/sis/tests/runtest
/opt/rtems-4.11/sparc-rtems4.11/sis/make
/opt/rtems-4.11/sparc-rtems4.11/sis/make/target.cfg
/opt/rtems-4.11/sparc-rtems4.11/sis/make/bsp.cfg
/opt/rtems-4.11/sparc-rtems4.11/sis/Makefile.inc

>
> The prefix for the configure command should then be located at the tools path
> (/opt/rtems-4.11) ?

Yes, this is the default.

>
> What's the correct location for Base path and BSP path in Eclipse?

Base path: "/opt/rtems-4.11"
BSP path: "/opt/rtems-4.11/sparc-rtems4.11/sis"

> Please tell me what do you do that made it work for you.
>
> I am using the CentOS virtual machine, just in case.
>
> Regards


-- 
Sebastian Huber, embedded brains GmbH

Address : Obere Lagerstr. 30, D-82178 Puchheim, Germany
Phone   : +49 89 18 90 80 79-6
Fax     : +49 89 18 90 80 79-9
E-Mail  : sebastian.huber at embedded-brains.de
PGP     : Public key available on request.

Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.


More information about the rtems-users mailing list