rtems gcc 4.6.1 can not compile stop at check TLS

Xiangfu Liu xiangfu at sharism.cc
Wed Aug 24 01:23:12 CDT 2011


the configure commands is like:
	(cd b-gcc/;\
	  ../gcc-$(GCC_CORE_VERSION)/configure --target=lm32-rtems4.11 \
	  --with-gnu-as --with-gnu-ld --with-newlib --verbose --enable-threads \
	  --enable-languages="c" --disable-shared --prefix=$(RTEMS_PREFIX); \
	 make all; \
	 make info; \
	)

more info see the attach makefile

On 08/24/2011 01:51 PM, Xiangfu Liu wrote:
> Hi
>
> I have tried compile lm32-rtems-gcc 4.6.1 with:
> ubuntu 11.04 64bit with gcc-core-4.6.1-rtems4.11-20110621.diff
> ubuntu 11.04 64bit with gcc-core-4.6.1-rtems4.11-20110715.diff
> $ gcc --version
> gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
>
>
> debian 6 32bit with gcc-core-4.6.1-rtems4.11-20110621.diff
> debian 6 32bit with gcc-core-4.6.1-rtems4.11-20110715.diff
> $ gcc --version
> gcc (Debian 4.3.2-1.1) 4.3.2
>
>
> all of them stop at: "checking whether the target assembler supports thread-local storage... "
> then 'cc1' eat all memories and swap. system became very very slow then.
>
> do I have to update my system gcc to 4.6.1? any help will be great.
>
> thanks in advance.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Makefile
URL: <http://www.rtems.org/pipermail/rtems-users/attachments/20110824/073891ff/attachment.ksh>


More information about the rtems-users mailing list