Problems building RTEMS for ARM on Ubuntu 64bit

Ralf Corsepius ralf.corsepius at rtems.org
Fri Nov 12 11:57:16 CST 2010


On 11/12/2010 06:44 PM, rtems at soulscythe.com wrote:
> I've removed all of the prebuild binaries and downloaded and recompiled
> a newer toolchain using this script
> https://github.com/esden/summon-arm-toolchain

This will not work - This toolchain is not suiteable for RTEMS.

Your initial report indicates your Ubunty installation contains a libgmp 
which incompatible to CentOS5's, even though Ubunty's libgmp.3 and 
CentOS5's carry the same SONAME.

=> Either Ubunty or CentOS's libgmp is broken.

Ralf



More information about the rtems-users mailing list