Still unable to build RTEMS 4.10 for PowerPC under WIN32

Sam Lost slostuk at gmail.com
Mon Nov 8 13:13:07 CST 2010


I have successfully been able to build the 4.10 psim and mcp750 BSP's, many
thanks to everyone that helped, especially Chris, Alan and Sebastian. The
problem appears to be how the files were extracted from CVS, I used tortoise
CVS using the UNIX file ending option. I have now extracted the files from
CVS using the MinGW command line, I have been able to run bootstrap and
build the psim and mcp750 BSP's. Now to get the eclipse integration working!
Regards

Sam
On Thu, Nov 4, 2010 at 4:40 PM, Cudmore, Alan P. (GSFC-5820) <
alan.p.cudmore at nasa.gov> wrote:

> Sam,
>
> This weekend I managed to install the latest MingW, the M68k/coldfire RTEMS
> 4.10 Mingw tools, successfully build RTEMS, and build an RTEMS hello world
> example.
> The only problem I had was actually checking out the RTEMS 4.10 release
> from CVS using the MingW/Msys shell and command line CVS client. For some
> reason that failed. I had to rely on a CVS checkout from a Linux VM to
> continue.
>
> Some details:
> - Using Windows 7 x64 host
> - Downloaded the mingw-get-inst MingW graphical installer to install mingw,
> C, C++ compilers, msys, and msys system builder options.
>  ( http://www.mingw.org/wiki/Getting_Started )
> - I did everything from the msys/bash shell ( bootstrap, configure, build
> etc. )
> - I did not have to replace M4, ( or even autoconf/automake for that matter
> ). The mingw compiler was GCC 4.5.x
>
> A few screen shots are attached of the mingw-get-inst tool options I chose.
>
> Let me know if you need any more details.
>
> Alan
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.rtems.org/pipermail/rtems-users/attachments/20101108/b32b6581/attachment.html>


More information about the rtems-users mailing list