bfin ezlite 537 gdb make all error

Ralf Corsepius ralf.corsepius at rtems.org
Wed Nov 3 10:15:04 CDT 2010


On 11/03/2010 03:40 PM, Sebastian Huber wrote:
> On 11/03/2010 03:28 PM, Eugene Shvets wrote:
>>> You are not providing sufficient information about what happens, nor are
>>> still have not providing any details about what you are trying to do.
>>    I am trying to install the nesessary tool to compile RTEMS on the host
>> computer.
>> I am following onlinedocs tutorial and currently on this step
>> http://rtems.org/onlinedocs/doc-current/share/rtems/html/started/started00051.html
>> --target was bfin-rtems4.11
>
> Unfortunately there are many getting started sources and not all of them are
> useful.  You may have a look at:
>
> http://wiki.rtems.org/wiki/index.php/RTEMS_Development_Hosts
>
> You should avoid to build the tool chain yourself.  Instead you should use the
> RPMs (or the archives for Windows).
Fully agreed.

We provide binaries for MinGW, Cygwin and openSuSE, Fedora, CentOS.

I.e. unless you are on a non-x86/x86_64 platform and using 
non-Windows/non-Linux OSes there hardly is any reason for rebuilding the 
toolchains yourselves.

Unfortunately you are not providing sufficent informations to be able to 
help.

>> When I execute make all I get error:
>> configure: error: configuration bfin-unknown-rtems4.11 is unsupported.
>> What else do you want me say?
FSF gdb-7.2 supports bfin-rtems* out of the box.

=> Wild guess:

The breakdown above likely originates from either
* something being broken/missing in your installation and you missing an 
earlier configuration/build error
* the way you are configuring gdb.
* you using an unsupported version of gdb.

Ralf



More information about the rtems-users mailing list