gcc-4.5.1 make all problem

Eugene Shvets lhj7362 at gmail.com
Mon Nov 1 10:19:17 CDT 2010


 Hi ,
I have problems compiling gcc-4.5.1. I decompressed

gcc-4.5.1.tar.gz,  gcc-core-4.5.1.tar.gz,
gcc-g++-4.5.1.tar.gz,  gcc-objc-4.5.1.tar.gz


files, patched with gcc-core-4.5.1-rtems4.11-20100818.diff
Then executed

../gcc-4.3.2/configure --target=bfin-rtems4.11 \
   --with-gnu-as --with-gnu-ld --with-newlib --verbose \
   --enable-threads --enable-languages="c,c++" \
   --prefix=/opt/rtems-4.11

command.

make all failed like this:

checking for bfin-rtems4.10-gcc...
/home/leednee/rtems/tools/b-gcc/./gcc/xgcc
-B/home/leednee/rtems/tools/b-gcc/./gcc/ -nostdinc
-B/home/leednee/rtems/tools/b-gcc/bfin-rtems4.10/newlib/ -isystem
/home/leednee/rtems/tools/b-gcc/bfin-rtems4.10/newlib/targ-include -isystem
/home/leednee/rtems/tools/gcc-4.5.1/newlib/libc/include
-B/opt/rtems-4.10/bfin-rtems4.10/bin/ -B/opt/rtems-4.10/bfin-rtems4.10/lib/
-isystem /opt/rtems-4.10/bfin-rtems4.10/include -isystem
/opt/rtems-4.10/bfin-rtems4.10/sys-include
checking for suffix of object files... configure: error: in
`/home/leednee/rtems/tools/b-gcc/bfin-rtems4.10/libgcc':
configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.
make[1]: *** [configure-target-libgcc] Error 1
make[1]: Leaving directory `/home/leednee/rtems/tools/b-gcc'
make: *** [all] Error 2

at config.log there were several errors :
conftest.c:16: error: 'choke' undeclared (first use in this function)
conftest.c:16: error: (Each undeclared identifier is reported only once
conftest.c:16: error: for each function it appears in.)
conftest.c:16: error: expected ';' before 'me'
conftest.c:10:28: error: ac_nonexistent.h: No such file or directory
conftest.c:55:27: error: libelf/libelf.h: No such file or directory
conftest.c:55:25: error: libelf/gelf.h: No such file or directory

Before running make I installed libelf (apt-file search libelf then install
what is searched). I couldn't find anything on ac_nonexistent
After some googling I found the problem mey be the absence of MPFR, GMP and
MPC  libraries, however I installed them before running make.

So what should I do?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.rtems.org/pipermail/rtems-users/attachments/20101101/d325f5c8/attachment.html>


More information about the rtems-users mailing list