Debian-host build error...

Ralf Corsepius ralf.corsepius at rtems.org
Tue Jun 30 10:25:13 CDT 2009


Ed Sutter wrote:
> 
> Ralf Corsepius wrote:
>> Ed Sutter wrote:
>>> Ian/Doran/Santosh,
>>> Well, the story continues...
>>> I managed to update my machine from etch to lenny (debain releases),
>>> and that allowed me to successfully execute the tools (almost)...
>>> Now the command "bfin-rtems4.10-gcc --help" actually prints the help
>>> message, I don't see the message...
>>>
>>>      bfin-rtems4.10-gcc: /lib/tls/i686/cmov/libc.so.6:
>>>      version `GLIBC_2.4' not found (required by bfin-rtems4.10-gcc)
>>>
>>> any more.
>>> So, with that, I took a blazing step forward and actually tried to
>>> compile a file with "bfin-rtems4.10-gcc main.c", and now I get this...
>>>
>>>    /opt/rtems-4.10/libexec/gcc/bfin-rtems4.10/4.4.0/cc1: 
>>> /lib/i686/cmov/libc.so.6:
>>>    version `GLIBC_2.8' not found (required by 
>>> /opt/rtems-4.10/libexec/gcc/bfin-rtem
>>>    s4.10/4.4.0/cc1)
>>>
>>> Somebody shoot me...
>> It's quite simple: You are facing another incarnation of the same issue 
>> again. The rpms you are unpackaging and trying to use on Debian are 
>> incompatible to those libraries you have installed on Debian.
> 
> Yep, I realize that, I was just posting to the list for reference in case
> someone else goes this route.  Note, I'm not complaining about the tools,
> just trying to share the info.
> 
>> Unfortunately, you are still providing too little details, to be able to 
>> help.
>>
>> * Which glibc compatiblity modes does it supply?
>> Run:
>> nm -sD /lib/libc.so.6 | grep GLIBC
> els:nm -sD /lib/libc.so.6 | grep GLIBC
> 00000000 A GLIBC_2.0
> 00000000 A GLIBC_2.1
> 00000000 A GLIBC_2.1.1
> 00000000 A GLIBC_2.1.2
> 00000000 A GLIBC_2.1.3
> 00000000 A GLIBC_2.2
> 00000000 A GLIBC_2.2.1
> 00000000 A GLIBC_2.2.2
> 00000000 A GLIBC_2.2.3
> 00000000 A GLIBC_2.2.4
> 00000000 A GLIBC_2.2.6
> 00000000 A GLIBC_2.3
> 00000000 A GLIBC_2.3.2
> 00000000 A GLIBC_2.3.3
> 00000000 A GLIBC_2.3.4
> 00000000 A GLIBC_2.4
> 00000000 A GLIBC_2.5
> 00000000 A GLIBC_2.6
> 00000000 A GLIBC_2.7
> 00000000 A GLIBC_PRIVATE

OK, this is too old for any Fedora. All current Fedoras are at Glibc-2.8 
or above.


>> * Which distro's rpms are you trying to use?
> 
> I'm running with Debian (lenny/stable).
> Following is the list of rpms I ran through alien and installed...
> 
> rtems-4.10-autoconf-2.63-2.fc10.noarch.rpm
> rtems-4.10-automake-1.11-1.fc10.noarch.rpm
> rtems-4.10-bfin-rtems4.10-binutils-2.19.1-1.fc10.i386.rpm
> rtems-4.10-bfin-rtems4.10-cpukit-4.9.99.0.20090206.2-1.fc10.noarch.rpm
> rtems-4.10-bfin-rtems4.10-gcc-4.4.0-6.fc10.i386.rpm
> rtems-4.10-bfin-rtems4.10-gcc-c++-4.4.0-6.fc10.i386.rpm
> rtems-4.10-bfin-rtems4.10-gdb-6.5-6.fc10.i386.rpm
> rtems-4.10-bfin-rtems4.10-newlib-1.17.0-39.fc10.i386.rpm
> rtems-4.10-binutils-common-2.19.1-1.fc10.i386.rpm
> rtems-4.10-gcc-common-4.4.0-6.fc10.i386.rpm
> rtems-4.10-gdb-common-6.8.50.20090329-2.fc10.i386.rpm
> rtems-4.10-newlib-common-1.17.0-39.fc10.i386.rpm

You could try to "alien"ize the CentOS5 rpms.

They only require glibc-2.4 and therefore likely are sufficiently 
compatible to your Debian.

Ralf



More information about the rtems-users mailing list