Debian-host build error...

Ralf Corsepius ralf.corsepius at rtems.org
Mon Jun 29 16:19:49 CDT 2009


Ed Sutter wrote:
> Ian/Doran/Santosh,
> Well, the story continues...
> I managed to update my machine from etch to lenny (debain releases),
> and that allowed me to successfully execute the tools (almost)...
> Now the command "bfin-rtems4.10-gcc --help" actually prints the help
> message, I don't see the message...
> 
>      bfin-rtems4.10-gcc: /lib/tls/i686/cmov/libc.so.6:
>      version `GLIBC_2.4' not found (required by bfin-rtems4.10-gcc)
> 
> any more.
> So, with that, I took a blazing step forward and actually tried to
> compile a file with "bfin-rtems4.10-gcc main.c", and now I get this...
> 
>    /opt/rtems-4.10/libexec/gcc/bfin-rtems4.10/4.4.0/cc1: /lib/i686/cmov/libc.so.6:
>    version `GLIBC_2.8' not found (required by /opt/rtems-4.10/libexec/gcc/bfin-rtem
>    s4.10/4.4.0/cc1)
> 
> Somebody shoot me...

It's quite simple: You are facing another incarnation of the same issue 
again. The rpms you are unpackaging and trying to use on Debian are 
incompatible to those libraries you have installed on Debian.


Unfortunately, you are still providing too little details, to be able to 
help.

E.g.

* Which glibc do you have installed?

* Which glibc compatiblity modes does it supply?
Run:
nm -sD /lib/libc.so.6 | grep GLIBC

* Which distro's rpms are you trying to use?

Ralf



More information about the rtems-users mailing list