Help with MinGW and 4.8 release candidate

Joel Sherrill joel.sherrill at oarcorp.com
Wed Jan 9 11:28:41 CST 2008


Chris Johns wrote:
> Joel Sherrill wrote:
>>
>> We need to figure out how to disable the newlib __assert.
>> On 4.9 builds, it it being used instead of the one in
>> RTEMS.  This negatively impacts code size because printf()
>> comes in again. :(
>>
>
> Is this a 4.8 issue as well ?
>
No.  I found the issue and apologize for the stir.  newlib 1.16.0
added a second __assert variant and we needed it in the
RTEMS assert implementation.  This is NOT a 4.8 issue at
all and fixed in RTEMS CVS.

The 4.8 tools issue is just that patch changed after 1.16.0
pointed out that we had a couple of POSIX API discrepancies.

Spin the MinGW tools. :-D

--joel
> Regards
> Chris




More information about the rtems-users mailing list