panic error with powerpc/virtex BSP

Joel Sherrill joel.sherrill at oarcorp.com
Tue Oct 2 07:01:16 CDT 2007


Jukka Pietarinen wrote:
> Pierre,
>
> Pierre Kestener wrote:
>> I am having problems in running the RTEMS helloworld example on a 
>> ML405 board (very similar to ML403). I made the FPGA design with the 
>> Xilinx EDK tool and then modified the xparameters_dflt.h that is in 
>> the RTEMS BSP with the one generated by EDK.
>>
>> When running the helloworld, i receive the following output:
>>
>> opb_intc_init: mask = 0x7
>> rtems-4.7.99.2(PowerPC/PowerPC 405/virtex) PANIC ERROR 5
>> system stopped, press RESET
>>
>> I am not sure to what refer the number 5 as a PANIC ERROR. Has 
>> someone an idea of what could done here ?
>
> I think there is a problem with the linkcmds of the virtex BSP in 
> 4.7.99.2. The linker script defines _end to be at the end of the .data 
> section whereas I think it should be defined to be at the end of .bss. 
> Please correct me if I'm wrong.
>
> Attached please find diff against a linkcmds I'm using for a Virtex II 
> Pro board.
>
I will commit this to the 4.8 branch and CVS head.  We went through this
back in August and I proposed a similar patch.  I don't know how it didn't
get merged.

--joel

> HTH.
>
> Regards,
> Jukka
>
> -- 
> Jukka Pietarinen
> Micro-Research Finland Oy
> ------------------------------------------------------------------------
>
> _______________________________________________
> rtems-users mailing list
> rtems-users at rtems.com
> http://rtems.rtems.org/mailman/listinfo/rtems-users




More information about the rtems-users mailing list