[Bug 1644] testsuites/tmtests/tm30/../../support/src/tmtests_support.c:46:3: warning: format '%d' expects type 'int', but argument 4 has type 'long int'

bugzilla-daemon at rtems.org bugzilla-daemon at rtems.org
Sun Aug 22 18:13:56 CDT 2010


https://www.rtems.org/bugzilla/show_bug.cgi?id=1644

--- Comment #1 from Joel Sherrill <joel.sherrill at oarcorp.com> 2010-08-22 18:13:55 CDT ---
Before patching the following tests have failures:

WARNING - log/psxaio01 did not appear to complete execution
WARNING - log/psxaio02 did not appear to complete execution
WARNING - log/psxenosys did not appear to complete execution
WARNING - log/sp70 did not appear to complete execution
WARNING - log/termios08 did not appear to complete execution

The first 3 are due to aio not working yet.  sp70 trips an unfixed bug which
has a PR.  termios08 is a test under construction and expected to fail right
now.

WARNING - log/block07 did not appear to complete execution
WARNING - log/block10 did not appear to complete execution
WARNING - log/psxaio01 did not appear to complete execution
WARNING - log/psxaio02 did not appear to complete execution
WARNING - log/psxenosys did not appear to complete execution
WARNING - log/sp07 did not appear to complete execution
WARNING - log/sp70 did not appear to complete execution
WARNING - log/termios08 did not appear to complete execution
WARNING - log/tm04 did not appear to complete execution
WARNING - log/tm17 did not appear to complete execution

I suspect that sp07 is a big hint as to what is broken.  It isn't THAT 
complicated of a test and it is broken.

-- 
Configure bugmail: https://www.rtems.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the rtems-bugs mailing list