[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Resurrecting MVME167



Well we just saw ticker run on it.  Some default
settings for the BSP are a bit surprising.  I would
like to hear from the community before changing
them.

+ Default console is NOT the MBug port.  It is
the second serial port.  Does this make sense for
a default?
+ Ditto for printk port.
+ printk support is disabled by default.
+ Load address is 0x800000.  Isn't this a bit
high in memory?  Usually I recall only seeing
addresses like 0x10000 or 0x20000 to skip
MBug RAM usage.
+ Defaults to getting settings from NVRAM
and ignoring configure overrides.  Since our
NVRAM was trashed, this didn't help matters.

Any comments on the above?  These just don't
seem consistent with the other BSPs.

--joel


On 03/23/2011 10:08 AM, Joel Sherrill wrote:
> Hi,
>
> We have an MVME167 here in the RTEMS lab which
> we would like to get working.  The RTC has been
> replaced so we have lost all settings.
>
> We have the console working for Mbug and
> can download a binary image. But once it
> downloads it, Mbug reports the size and
> nothing else is displayed.
>
> I see on the list that folks have them
> working.  Can someone provide some guidance
> in getting this one running here?
>
> Thanks.
>


-- 
Joel Sherrill, Ph.D.             Director of Research&  Development
joel.sherrill at OARcorp.com        On-Line Applications Research
Ask me about RTEMS: a free RTOS  Huntsville AL 35805
    Support Available             (256) 722-9985