[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

NFS timeouts without optimization



I'm putting together an embedded web server on an MPC55xxevb (MPC5554 Phytec) system.  After I got the basics working I put the HTTP on NFS for ease of development.  I started getting NFS timeouts whenever a browser tried to load the RTEMS .jpg file:

[/] # mongoose document_root /data/http listening_ports 80 stacksize 0xc000
Loading filesystem image...
Mongoose 3.0 started on port(s) [80], serving directory [/data/http]
[/] # NFS (proc 6) - RPC: Timed out
[/] # ls -l data/http/rtems_logo.jpg
-rw-rw-r--  1 500  500  14586 Mar  6  2011 data/http/rtems_logo.jpg
[/] # 

On a hunch I rebuilt with -O2 back on (I'd turned it off a while ago for debugging) and now it works fine.

This isn't a bug report, obviously, it's a "has anyone else seen this?" question.  The ethernet driver is one I brought up, the smc91111, which I think had previously only been used on Sparc.  I'm going to ignore the issue today unless it comes back with the optimization on.

Peter
-----------------
Peter Dufault
HD Associates, Inc.      Software and System Engineering