[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

EL6 RPMs for Fedora 14 Issue



On 12/22/2011 04:25 AM, Ralf Corsepius wrote:
> On 12/21/2011 07:58 PM, Joel Sherrill wrote:
>> On 12/21/2011 12:42 PM, Ralf Corsepius wrote:
>>> On 12/21/2011 07:19 PM, Joel Sherrill wrote:
>>>> Hi,
>>>>
>>>> I still have Fedora 14 on one of my computers at home. I know it should
>>>> be upgraded but I don't have the time nor inclination at the moment.
>>>> Wnen I tried to switch over to the el6 RPMs, I get this message and
>>>> apparently the libpython is not available for Fedora 14 based on the
>>>> yum provides output.
>>>>
>>>>
>>>> Error: Package: rtems-4.11-bfin-rtems4.11-gdb-7.3.91-1.el6.i386
>>>> (rtems-4.11)
>>>> Requires: libpython2.6.so.1.0
>>>> You could try using --skip-broken to work around the problem
>>>> ** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
>>>> rhpl-0.221-2.i686 has missing requires of libpython2.6.so.1.0
>>>> rhpl-0.221-2.i686 has missing requires of python(abi) = ('0', '2.6',
>>>> None)
>>>> bash-4.1# yum provides "*libpython2.6.so.1.0*"
>>>> Loaded plugins: refresh-packagekit
>>>> No Matches found
>>>> bash-4.1#
>>>>
>>>> Any suggestions?
>>> I already mentioned it 2 times before:
>>>
>>> http://www.rtems.org/pipermail/rtems-users/2011-December/009263.html
>>>
>>> http://www.rtems.org/pipermail/rtems-devel/2011-December/000067.html
>>>
>>> In brief: You are facing the ugliness of python's versionitis.
>>>
>>> The only short time workaround I am currently aware about is to switch
>>> to using the CentOS5 packages instead of the CentOS6 packages on Fedora
>>> 14 (edit /etc/yum.repos.d/rtems-4.11.repo to point to the CentOS5
>>> packages instead of the CentOS6 packages).
>>>
>>> So far, I don't understand why this works (but also haven't
>>> investigated),

The CentOS6 rtems*gdb packages are dynamically linked against python2.6.

The fedora-14 rtems*gdb packages were dynamically linked against 
python2.7, those of later Fedoras are dynamically linked against more 
recent versions of python.

=> CentOS6's and the Fedoras' pythons are in are incompatible

As Fedora doesn't ship python2.6 backward-compatibility packages, 
installing the CentOS6-built gdb-packages on Fedora 14 or later fails.


The CentOS5 rtems*gdb packages are statically linked against python2.4. 
Disgusting as this is in general, this is the reason why they install 
without any complaint on Fedora 14.


>>> in particular because CentOS5's python is even older than
>>> the already version in CentOS6.
>>>
>>> The only clean solution is upgrade to Fedora>= 15 or a different
>>> distro. Fedora 14 is dead.
>> That's the plan but not in the next few days.
>
> Then you will want to try what I wrote above (edit
> /etc/yum.repos.d/rtems-4.11.repo) and check if this helps.

For now, I've redirected the fedora-14 legacy links inside of the repos 
to CentOS5. This should prevent future cases like the one you are 
currently facing.

Unfortunately, I am not aware of any way to automate helping you out of 
your problems. You will have to manually edit 
/etc/yum.repos.d/rtems-4.11.repo to let your yum configuration point to 
the centos 5 repositories.


All in all, in longer terms, I fear the only applicable approach is to 
stop providing legacy packages and to cut off discontinued distros the 
hard way.

Ralf