[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems getting started with PC686 BSP



I'd try the same grub (boot sector + further stages + menu)
you are using on your laptop with qemu in order to find out
if it's a problem of that particular grub.

If that doesn't help - grep the grub sources for ERR_EXEC_FORMAT
to find the places that could cause the error message you observe.
Maybe that gives you a clue...

HTH
-- Till


On 09/15/2010 10:58 AM, Steven Grunza wrote:
>> -----Original Message-----
>> From: Ralf Corsepius [mailto:ralf.corsepius at rtems.org]
>> Sent: Wednesday, September 15, 2010 11:41 AM
>>      
>> To: Steven Grunza
>> Cc: rtems-users at rtems.org
>> Subject: Re: Problems getting started with PC686 BSP
>>
>> On 09/15/2010 04:16 PM, Steven Grunza wrote:
>>      
>>> I've been trying to get the hello_world example to work on a Dell
>>>        
>> laptop
>>      
>>> without success.
>>>        
>>      
>>> I'm using a USB boot from a flash drive (the laptop doesn't have
>>>        
>> a
>>      
>>> floppy drive).
>>>        
>>      
>>> My grub.conf is:
>>>
>>> default=0
>>> timeout=15
>>> title RTEMS pc686-tests-hello.exe
>>>           root (hd0,0)
>>>           kernel /boot/images/pc686-tests-hello.exe
>>>        
>> Note: root(hd0,0)
>>
>>      
>>> J:\>dir /s
>>>    Volume in drive J has no label.
>>>    Volume Serial Number is 4C8F-D1DD
>>>        
>> Note: Drive "J:"
>>
>> This doesn't match.
>>      
>
> The machine I used to grab the directory listing isn't the same machine on which I'm testing.  Sorry for the confusion.
>
> The laptop I'm trying to use for testing is a Dell Latitude D400 with an NTFS formatted internal drive (not mine so I don't want to re-image the internal drive).  The BIOS is set to boot from USB storage first.  Booting a USB flash drive formatted with MS-DOS results in drive "C:" being the flash drive.  Booting my USB flash drive with GRUB brings up the GRUB menu.  Since it can find the .ralf image (but doesn't like it) is it correct to assume that the correct root setting is (hd0,0)?
>
>
>    
>> grub's (hd0,0) would be the first partion on the first hard-disk
>> (In DOS
>> terms: Drive "C:").
>>
>> An USB stick DOS sees as "J:" (9th drive) is very unlikely to be
>> grub's
>> (hda,0).
>>
>> What I actually is is hard to tell, because both Linux and grub
>> don't
>> number drives by consecutive letters.
>>
>> What is the drive name Linux sees your flash drive rsp. the
>> partition on
>> the flash drive?
>>
>>      
> I'm not sure I understand your question but my build machine is a Linux box running CentOS5.  The flash drive shows up as /dev/sdb and I mount the /dev/sdb1 partition to /mnt in order to copy files to the flash drive.
>
> [root at stm32dbg /]# fdisk -l /dev/sdb
>
> Disk /dev/sdb: 2021 MB, 2021654528 bytes
> 63 heads, 62 sectors/track, 1010 cylinders
> Units = cylinders of 3906 * 512 = 1999872 bytes
>
>     Device Boot      Start         End      Blocks   Id  System
> /dev/sdb1   *           1        1010     1972499    b  W95 FAT32
>
> If I boot with the GRUB USB flash drive and enter the command line menu I can enter
>
> find (hd0,0)/boot/im
>
> and then press the {TAB} key.  The line then changes to
>
> find (hd0,0)/boot/images/
>
>
> GRUB responds to the command "find /boot/images/pc686-hello.exe" with "(hd0,0)"
>
>
>
>
> _______________________________________________
> rtems-users mailing list
> rtems-users at rtems.org
> http://www.rtems.org/mailman/listinfo/rtems-users
>