[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Nios2 problems when building tests



Thanks, any help is greatly appreciated.

The status for me right now is that I have switched to newlib-1.17.0.  I also changed both cpukit/wrapup/Makefile.am and c/src/wrapup/Makefile.am, as suggested.
That fixed most errors, now that both librtemscpu.a and librtemsbsp.a are added correctly.

I've tried myself to solve the remaining issues, by including /shared/bsppretaskinghook.c to libbsp.a, and define WorkAreaBase in linkcmds.
However the resulting tests fail in the simulator, so that might not have been the right way to go, or there are other things to consider aswell.

Looking forward to your inputs.

//Roger


________________________________________
Fr?n: millibit at gmail.com [millibit at gmail.com] för Morten Kristiansen [millibit+rtems at gmail.com]
Skickat: den 24 mars 2009 09:30
Till: Joel Sherrill
Kopia: Roger Dahlkvist; rtems-users at rtems.com
?mne: Re: Nios2 problems when building tests

2009/3/20 Joel Sherrill <joel.sherrill at oarcorp.com>:
> My full NIOS patches are at home.  Morten can help you
> get things going.
I should think so. I'll take a look at it this evening.

> The biggest issue you are facing is that the NIOS II binutils
> version Altera uses is TOO old for the feature used in cpukit/wrapup.
I fetched the relevant versions into Subversion and tried merging. It
wasn't straightforward, but as a quick solution I can create a patch
that allows it to read options from a file.

/MK