[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

yum update for powerpc-gdb (fedora8)



Gene Smith wrote:
> I was under the impression that no further updates would occur for f8 
> for rtems tools. 

Correct. We discontinued building the toolchains for Fedora 8 and 
redirected the Fedora 8 repos to those of CentOS 5, as legacy to users 
who for some reasons can't upgrade to a newer Fedora.

Side-effects of this:
* Fedora 8 users, who have the original fc8-compiled toolchains 
installed, will see their rtems packages gradually be replaced with 
CentOS5 compiled ones, in cases of toolchain updates or when 
reinstalling rtems toolchain packages.

* Fedora 8 users, who freshly install the rtems toolchains, will receive 
CentOS5 compiled packages.

> Today, on reboot after running about 4 months, I saw an 
> update message for upgrading powerpc-gdb but I only have ARM installed. 
> The details indicated it was not actually powerpc specific so I allowed 
> the upgrade.
> 
> Here is what I had before the upgrade:
> 
> rpm -qa | grep rtems.*4\.9.*gdb
> rtems-4.9-arm-rtems4.9-gdb-6.8-4.fc8
> rtems-4.9-gdb-common-6.8-4.fc8
> 
> After:
> 
> rpm -qa | grep rtems.*4\.9.*gdb
> rtems-4.9-arm-rtems4.9-gdb-6.8-4.fc8
> rtems-4.9-gdb-common-6.8-6.el5
> 
> The versions don't match and the common one is for "el5" not "fc8" it 
> seems. Is this OK?

Yes, this is OK.

What you are observing is a side effect of the powerpc-rtems4.9-gdb 
toolchain having received a bugfix update. You received the latest 
"*-common" package all gdbs share, from CentOS 5 (dist-tag .el5).

Ralf