[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Interrupt Manager



frank.ueberschar at dsa-volgmann.de wrote:
> To whom it may concern,
>  
> we are using RTEMS 4.5.1 with a selfmade BSP for
> the Coldfire 5272. Now I want to try to build a new
> bsp for the 5282 - using the same RTEMS Version.
>  
You really really really need to upgrade your RTEMS.
Ignoring the RTEMS changes, the tool version is ancient
and the Coldfire support is questionable.  RTEMS itself
has much better Coldfire support in more recent versions.

I am not even sure the Coldfire existed when 4.5.1 was released.
> I wonder if someone could give me a hint on the
> different interrupt processing of the cpu's:
>  
> Does this affect RTEMS Kernel-Code (or is this
> simply regarding our own ISRs and startupcode to
> be used with the new board support package) ?
>  
If you were using a recent RTEMS version, the changes
would strictly be in your BSP since the core code already
knows about the Coldfire.

--joel
>  
> With kind regards,
> Frank Ueberschar
> ---------------------------------------
> DSA-Volgmann
> Thomas Volgmann
> Redcarstr. 20
> 53842 Troisdorf
>  
> Tel:    02241 23416 16
> Fax:    02241 23416 666
> email : _frank.ueberschar_ at dsa-volgmann.de 
> <mailto:frank.ueberschar at dsa-volgmann.de>
> web:    www.dsa-volgmann.de <http://www.dsa-volgmann.de/>
> ---------------------------------------
> ------------------------------------------------------------------------
>
> _______________________________________________
> rtems-users mailing list
> rtems-users at rtems.com
> http://rtems.rtems.org/mailman/listinfo/rtems-users
>