[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

autoconf on CVS source



On Sun, 2007-11-18 at 11:55 -0500, Hoan Hoang wrote:
> Hi,
> 
>    I got rtems from CVS.  It doesn't contains the configure script so I 
> ran autoconf and got an error.
> 
> configure.ac:19: error: possibly undefined macro: AM_INIT_AUTOMAKE

> what should I do ? I can't autoconf so can't configure, can't build

Install autoconf and automake.

Then
cd <root-of your cvs checkout>
./bootstrap

Which versions of automake/autoconf to use and how to install them
depends on the OS you are using.

The versions being shipped by modern Linuxes probably will suffice
(CVS-HEAD needs autoconf >= 2.61, automake-1.10).

Users of older rpm-based Linuxes can use the rpms to be found on
ftp.rtems.org (for CVS-HEAD you will want the rtems-4.9-* packages).

Users of other OS will have check the versions their vendors might be
shipping or will have have to resort to install from sources (to be
found on any gnu-mirror)

Ralf