[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

No acceptable C compiler found



Hi Ralf,

 I have set  <arm tool install point>/bin  in the $ PATH which include
arm-rtems4.7-gcc.exe , autoconf etc.  files.    I am not doing any thing
with the cc1.
 I am also giving prefix in configure command like - -
prefix=/h/RTEMS/msys/arm/bin    . As I said prefix has no effect. If it has
then why it is giving error for $PATH like "No acceptable  C compiler found
in $PATH" ?

 Regards.





On Tue, 2007-11-13 at 07:59 -0600, Joel Sherrill wrote:
> + MinGW doesn't run on Vista correctly.  The native compiler
>     dies compiling hello world with a message like
>      "cc1 not found".
cc1 not found indicates a toolchain relocation error.
In general, GCCs based toolchains are not relocatible and must be
installed into the prefix they have been configured for.

>  We searched online and others have
>      run into this but the only solution I saw was to put the
>      directory with cc1 in your PATH but that results in the
>      RTEMS cross compiler finding the native cc1 not the
>      cross one.
Right. As you might recall, cross tools are named <host>-<tool>.

You MUST not put the directory containing cc1 into $PATH.

Ralf


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rtems.rtems.org/pipermail/rtems-users/attachments/20071113/0b0b2787/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: graycol.gif
Type: image/gif
Size: 105 bytes
Desc: not available
Url : http://rtems.rtems.org/pipermail/rtems-users/attachments/20071113/0b0b2787/attachment-0001.gif