[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

automake problem on window



hi,

  I am doing my working under 4.7.1, so I download  rtems4.7-i386-4.exe from
  http://www.rtems.com/ftp/pub/rtems/windows/4.7/,
  and after I installed it,   automake-1.10 is in bin subdirectory.

  and rtems-4.7.1 is configured with autoconf 2.60 and automake 1.10,
  but rtems4.7-i386-4.exe contains autoconf 2.61 and automake 1.10,
       rtems4.7-i386-3.exe contains autoconf 2.60 and automake 1.9
  maybe here is a mismatch.



2007/11/10, Chris Johns <chrisj at rtems.org>:
> ?? wrote:
> > hi,
> >
> >   I am migrating my development enviroment from linux to windows.
> >   I followed the wiki page, installed mingw, msys, msysDTK.
> >
> >   I installed rtems4.7-i386-4.exe to c:\rtems\i386
> >   and mingw to c:\mingw
> >   and msys, msysDTK to there default path.
> >
>
> Which Wiki page refers to rtems4.7 ?
>
> The current version is for rtems4.8 and build 16.
>
> >   my /etc/fstab:
> >
> >  c:/MinGW /mingw
> >  C:/rtems/i386 /home2/work/chris/rtems/4.7/build/rpms
> >
> >  and it works very when building rtems and apps
> >
> >  but automake got a problem:
> >
> > $automake-1.10
> > Can't locate Autom4te/General.pm in @INC (@INC contains:
> > /usr/share/autoconf /usr/lib/perl5/5.6.1/msys /usr/lib/perl5/5.6.1
> > /usr/lib/perl5/site_perl/5.6.1/msys /usr/lib/perl5/site_perl/5.6.1
> > /usr/lib/perl5/site_perl .) at /usr/bin/autom4te line 40.
> > BEGIN failed--compilation aborted at /usr/bin/autom4te line 40.
> > automake-1.10: autoconf failed with exit status: 2
> >
>
> Where did you get automake-1.10 from ?
> What does 'which automake-1.10' say ?
>
> Regards
> Chris
>