[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Unable to load examples for RTEMS for GBA



Hi Joel,

I too am using Linux (Slackware 12 :) ). I downloaded VisualBoyAdvance
1.7.1 for Linux (Linux + SDL + glibc22) from the main site. I built my
RTEMS and GCC based on the instructions from:

http://www.rtems.com/wiki/index.php/RTEMSAda

In addition to the EXEs under testsuite, I tried compiling a simple
Ada hello program following the documentation on the RTEMSAda Wiki. It
too failed with the same error.

When I get home, I'll try BoyCott Advance.


On Nov 8, 2007 12:54 PM, Joel Sherrill <joel.sherrill at oarcorp.com> wrote:
> Micronian wrote:
> > Hi,
> >
> > I just built RTEMS 4.8 and GCC 4.2.2 using target=arm-rtems and
> > selected the gba BSP. I read somewhere on the mailing list that it is
> > possible to load the EXE files (under testsuites) in a emulator. I
> > downloaded VisualBoyAdvance but when I try to load one of the EXEs
> > (e.g. hello.exe) it says "Unknown file type". I don't have a real GBA
> > to play with, so that is why I need an emulator.
> >
> >
> I'm on Linux and tried ticker.exe built from the CVS head.
> It ran using a GBA simulator named BoyCott Advance
> that I downloaded a while back.
>
> I have only found a MS-Windows VisualBoyAdvance version.
> If you have a GNU/Linux one, I would like to know.
>
> > Can anyone shed some light? This is my first time exploring RTEMS.
> >
> > Thanks!
> > _______________________________________________
> > rtems-users mailing list
> > rtems-users at rtems.com
> > http://rtems.rtems.org/mailman/listinfo/rtems-users
> >
>
>