[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem when installing 4.8 using yum.



Joel Sherrill <joel.sherrill at oarcorp.com> writes:
> Sergei Organov wrote:
>> Hello,
>>
>> I'm trying to install RTEMS tools using yum (3.0.3) on FC6.
>>
>> # yum -c /etc/yum/yum.rtems.com install rtems-4.8-automake-rtems
>> ...
>> Downloading Packages:
>> (1/2): rtems-4.8-autoconf 100% |=========================| 623 kB    00:03
>> (2/2): rtems-4.8-automake 100% |=========================| 598 kB    00:03
>> warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 69ce4a83
>>
>>
>> Public key for rtems-4.8-autoconf-2.61-5.noarch.rpm is not installed
>> #
>>
>> How do I fix this?
>>
> By importing the gpg key used to sign the packages.  Most, if not all,
> of the packages
> should be built with the first key:
>
> rpm --import
> ftp://ftp.rtems.org/pub/rtems/linux/gpg-pubkey-69ce4a83-44cc2b30
> rpm --import ftp://ftp.rtems.org/pub/rtems/gpg-pubkey-EAC29B6F

Thanks, will you care to add this information to the
<http://www.rtems.com/wiki/index.php/APT/Yum_Repository>?

(I've temporarily overcome the problem by setting gpgcheck=0 in the YUM
config before I got your response.)

BTW, I've figured out that in FC6, there is another way to configure
YUM.  It is to add a config file, say, called 'rtems-com.repo', to the
'/etc/yum.repos.d' directory. This file should not contain [main]
section, e.g.:

# cat /etc/yum.repos.d/rtems-com.repo
[rtems-4.8]
name=RTEMS-4.8 - $basearch
baseurl=ftp://ftp.rtems.com/pub/rtems/linux/4.8/redhat/7.3/$basearch
gpgcheck=1
#

After that

# yum install rtems-4.8-powerpc-rtems4.8-c++

works without '-c' option.

-- Sergei.