[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem when installing 4.8 using yum.



Sergei Organov wrote:
> Hello,
>
> I'm trying to install RTEMS tools using yum (3.0.3) on FC6.
>
> # yum -c /etc/yum/yum.rtems.com install rtems-4.8-automake-rtems
> ...
> Downloading Packages:
> (1/2): rtems-4.8-autoconf 100% |=========================| 623 kB    00:03
> (2/2): rtems-4.8-automake 100% |=========================| 598 kB    00:03
> warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 69ce4a83
>
>
> Public key for rtems-4.8-autoconf-2.61-5.noarch.rpm is not installed
> #
>
> How do I fix this?
>   
By importing the gpg key used to sign the packages.  Most, if not all, 
of the packages
should be built with the first key:

rpm --import 
ftp://ftp.rtems.org/pub/rtems/linux/gpg-pubkey-69ce4a83-44cc2b30
rpm --import ftp://ftp.rtems.org/pub/rtems/gpg-pubkey-EAC29B6F

This is needed any time you add a new source of RPMs.
> [Disclaimer: I usually use Debian-based systems, so have almost no clue
> on how yum works]
>
>   
Well most of the time and frustrating when it doesn't. :)

-joel
> -- Sergei.
> _______________________________________________
> rtems-users mailing list
> rtems-users at rtems.com
> http://rtems.rtems.org/mailman/listinfo/rtems-users
>