[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with RTEMS-4.7.1 pc386 BSP



On Thu, 2007-05-24 at 08:17 -0500, Joel Sherrill wrote:
> Till Straumann wrote:
> > I build with this BSP occasionally but haven't upgraded to 4.7.1yet
> > libcsupport/src/__assert.c was apparently added to 4.7.1(but was
> > missing from 4.7.0) on 2007/3/28 so it's relatively new.
> >
> >   
> Yes it is new.  The __assert in newlib used printf so was almost guaranteed
> to be unable to print when you needed to assert.
Why has this change been introduced to 4.7.x?

It apparent was added post 4.7.0:
        rtems-4-7-1: 1.1.2.2
        rtems-4-7-branch: 1.1.0.2

=> You've broken the API.

> The RTEMS __assert ends with rtems_fatal_error_occurred so it makes
> sense to me that the pc386 BSP provide a fatal error handler and use
> the default _assert.
Frankly speaking, I don't like this approach.

Ralf