[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem when running hello_world_c with RTEMS 4.7.1 for SPARC



Fabr?cio de Novaes Kucinskis wrote:
> Hi all,
>
>
> Yesterday, I've downloaded RTEMS 4.7.1, and built it to the ERC32 (SIS) BSP.
> I've compiled hello_world_c and tried to execute it in GDB ("target sim").
>
>   
Are you using the erc32 or sis BSP to run on gdb's simulator?  The sis BSP
enables extra initialization not required on the real hardware. 
> To my surprise, there was no output. The executable stops when calling
> rtems_initialize_executive_early.
>
> When looking the BSP source files and comparing it to the ones in 4.6.4
> version, I noticed that, in ...lib/libbsp/sparc/shared/start.S, there was no
> call to __bsp_board_init (+/- line 640). I added that call and voil?!
> Everything works well now.
>
> I don't think this call would be removed without a reason, but the absence
> of it was (I think) my problem. I'd like to confirm if this is the real
> problem (and sure, inform it), or if there's something else that I'm not
> getting here.
>
> Thanks in advance and best regards,
>
>
> Fabr?cio de Novaes Kucinskis - DEA / INPE
> -----------------------------------------
> Grupo de Supervis?o de Bordo - SUBORD
> Divis?o de Eletr?nica Aeroespacial
> Instituto Nacional de Pesquisas Espaciais
>
> _______________________________________________
> rtems-users mailing list
> rtems-users at rtems.com
> http://rtems.rtems.org/mailman/listinfo/rtems-users
>