[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Which patch should I use for gcc ?



On Wed, 2007-05-02 at 14:10 +0000, Vivian Paola Guerrero Rodriguez
wrote:
> Hi, i'm trying to build gcc 4.1.1 with binutils 2.17 and newlib 1.15.0 , but 
> i don't find the patch file for gcc 4.1.1 that appears on-line Library.

Which OS are you using? There exist prebuilt toolchains for rpm-based
Linux systems.

> I have been searching on the ftp://ftp.rtems.com/pub/rtems/SOURCES/ page, 
> and I just find
> 
> gcc-4.1.1-bfinrtems-20060810a.diff
> gcc-core-4.1.1-rtems4.7-20070102.diff
> 
> and others like these.
For rtems4.7, you normally will want to use the latest
binutils-rtems4.7-<date>.diff
gcc-core-rtems4.7-<date>.diff
newlib-rtems4.7-<date>.diff
patches.

> What path should I use for gcc ?
What ever you prefer. 

It only needs to be the same for both binutils and gcc+newlib.

> Which is the difference between these patches?
Have a look into them - Bug fixes, extensions, ... 

Ralf