[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Which patches should I use for binutils, gcc and newlib?



On Tue, 2007-01-30 at 12:22 -0800, Till Straumann wrote:
> >
> > Amalaye Oyake wrote:
> > >
> > > Hello,
> > >
> > > I am trying to build Binutils Gcc (4.1.1) and Newlib on a 64bit Xeon 
> > > host box running Ubuntu (64bit) ? my target system will be a i386 box. 
> > > What are the correct patches for Binutils, Gcc and Newlib? I see a lot 
> > > of /.diff/ files in http://www.rtems.com/ftp/pub/rtems/SOURCES/ that I 
> > > don?t know if I am to use all of them or just the latest one ?
> > >
> > In general, it is always a single patch and choose the one with the 
> > latest date. That
> > may NOT be the case for specific CPUs which may not work with the latest 
> > version
> > of something or require a special patch.
> >
> >   
> 
> Just for the record...
> > For specific and absolutely correct information, check out
> >   
> I assume you mean to look in CVS. If I browse in cvsweb
> to [there is no 'rtems-XXX', just 'rtems']
> 
> rtems/contrib/crossrpms/rtems4.7/<my_cpu>
> 
> then I end up an the 'Attic' 

Attic, because the rtems4.7 toolchain sources are not on CVS HEAD, but
on the rtems-4-7-branch, only.

Ralf