[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Which patches should I use for binutils, gcc and newlib? *limits.h*



Amalaye Oyake wrote:
>
> I should have been more specific. I asked what patch I should use b/c 
> I was bombing out compiling gcc 4.1.1 ? it complains about limits.h
>
This looks like a configure problem. What command did you configure 
with? Did you include --with-newlib?
>
> make[4]: Entering directory `/home/coder/RTEMS/build-gcc/gcc'
>
> make[4]: `crtend.o' is up to date.
>
> make[4]: Leaving directory `/home/coder/RTEMS/build-gcc/gcc'
>
> /home/coder/RTEMS/build-gcc/./gcc/xgcc 
> -B/home/coder/RTEMS/build-gcc/./gcc/ 
> -B/home/coder/RTEMS/tools/i386-rtems/bin/ 
> -B/home/coder/RTEMS/tools/i386-rtems/lib/ -isystem 
> /home/coder/RTEMS/tools/i386-rtems/include -isystem 
> /home/coder/RTEMS/tools/i386-rtems/sys-include -O2 
> -I../../gcc-4.1.1/gcc/../newlib/libc/sys/rtems/include -O2 -g -O2 
> -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes 
> -Wmissing-prototypes -Wold-style-definition -isystem ./include -g 
> -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED 
> -Dinhibit_libc -I. -I. -I../../gcc-4.1.1/gcc -I../../gcc-4.1.1/gcc/. 
> -I../../gcc-4.1.1/gcc/../include 
> -I../../gcc-4.1.1/gcc/../libcpp/include -DL_fixunsdfsi -c 
> ../../gcc-4.1.1/gcc/libgcc2.c -o libgcc/./_fixunsdfsi.o
>
> In file included from 
> /home/coder/RTEMS/build-gcc/./gcc/include/syslimits.h:7,
>
> from /home/coder/RTEMS/build-gcc/./gcc/include/limits.h:11,
>
> from ../../gcc-4.1.1/gcc/libgcc2.c:1469:
>
> /home/coder/RTEMS/build-gcc/./gcc/include/limits.h:122:61: error: no 
> include path in which to search for limits.h
>
> make[3]: *** [libgcc/./_fixunsdfsi.o] Error 1
>
> make[3]: Leaving directory `/home/coder/RTEMS/build-gcc/gcc'
>
> make[2]: *** [stmp-multilib] Error 2
>
> make[2]: Leaving directory `/home/coder/RTEMS/build-gcc/gcc'
>
> make[1]: *** [all-gcc] Error 2
>
> make[1]: Leaving directory `/home/coder/RTEMS/build-gcc'
>
> make: *** [all] Error 2
>
> Ho do I fix this?
>
> -AO
>
> ------------------------------------------------------------------------
>
> *From:* rtems-users-bounces+amalaye.oyake=jpl.nasa.gov at rtems.org 
> [mailto:rtems-users-bounces+amalaye.oyake=jpl.nasa.gov at rtems.org] *On 
> Behalf Of *Amalaye Oyake
> *Sent:* Wednesday, January 24, 2007 10:23 PM
> *To:* rtems-users at rtems.org
> *Subject:* Which patches should I use for binutils, gcc and newlib?
>
> Hello,
>
> I am trying to build Binutils Gcc (4.1.1) and Newlib on a 64bit Xeon 
> host box running Ubuntu (64bit) ? my target system will be a i386 box. 
> What are the correct patches for Binutils, Gcc and Newlib? I see a lot 
> of /.diff/ files in http://www.rtems.com/ftp/pub/rtems/SOURCES/ that I 
> don?t know if I am to use all of them or just the latest one ?
>
> Regards,
>
> * Amalaye Oyake *
>
> * Flight Software Applications & Data Product Mgmt */\
>
> * 818.393.7168 work 818.653.4748 cell *||
>
> * Jet Propulsion Laboratory, Pasadena CA 91109 */||\
>
> @@@ personal opinions expressed represent only the views of the author @@@
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> rtems-users mailing list
> rtems-users at rtems.com
> http://rtems.rtems.org/mailman/listinfo/rtems-users
>