[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Checking for 4.6.6 or 4.6.5



On Sat, 2006-12-30 at 12:27 +0100, Johnny Willemsen wrote:
> Hi,
> 
> Is there any way how we can check in our code whether we build against RTEMS
> 4.6.6 or 4.6.5? I can check major and minor versions but I can't find a
> define for the third digit.

1. RTEMS is supposed to be API compatible within one series of
"MAJOR-MINOR" releases. The 3rd digit should not be of any significance.

2. Such a define exists: __RTEMS_REVISION__
Unfortunately, it seems to be broken in all current versions of RTEMS
(I'd guess, probably nobody has used it for many years, which had cause
this problem to slip through unnoticed ;))

3. You should be aware that target characteristics/features can vary
depending on compilation flags (i.e. can vary for different variants of
the same target within of the same release, e.g. between different
multilibs of a target), toolchain component versions and many more
factors => Version numbers, in general, are of very limited use.

Ralf