[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem when compiling gcc for rtems-4.6 toolchain



Hi Dominik,

When we built gcc recently, this is the configure line we used (just 
replace m68k-rtems with sparc-rtems):

  ../gcc-3.2.3/configure --target=m68k-rtems --with-gnu-as --with-gnu-ld 
--with-newlib --verbose --enable-threads --enable-languages='c,c++' 
--prefix=/opt/rtems323

Note the with-gnu-as and with-gnu-ld.

I hope this helps.

regards,

Ian Caddy


Dominik Brader wrote:
> Hello, 
> 
> I have a problem when compiling the gcc for the RTEMS-4.6. toolchain.
> I am using binutils-2.13.2.1, gcc-3.2.3 with gcc-3.2.3-rtems-20040420.diff 
> patch and newlib-1.11.0 with newlib-1.11.0-rtems-20030605.diff patch. 
> 
> My configuration for the gcc is: 
> ../gcc-3.2.3/configure --target=sparc-rtems --enable-languages="c,c++" 
> --prefix=$PREFIX --with-newlib 
> --with-headers=$TOOLCHAIN/newlib-1.11.0/libc/include
> 
> The Error message is attached below.
> The native compiler on the system is gcc-3.2.3, but I also tried gcc-3.3.2 
> with the same result. 
> The strange thing about it is that it works fine if I just configure without 
> c++ support. But then I can't compile RTEMS, is that right?
> 
> Can anybody help me with this? 
> 
> Dominik 
> 
> ---
> Error-Message:
> ...
> gcc -DIN_GCC -DCROSS_COMPILE   -g -O2 -W -Wall -Wwrite-strings 
> -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic 
> -Wno-long-long  -DHAVE_CONFIG_H  gcov.o intl.o 
> version.o   ../libiberty/libiberty.a -o gcov
> /opt/TWWfsw/gcc332/i686-pc-linux-gnu/bin/ld: cannot open crt0.o: No such file 
> or directory
> collect2: ld returned 1 exit status
> make[1]: *** [gcov] Error 1
> make[1]: Leaving directory 
> `/home/braderdo/project-work/rtems/sparc-rtems-toolchain2/tools/build-gcc/gcc'
> make: *** [install-gcc] Error 2
> 

-- 
Ian Caddy
Goanna Technologies Pty Ltd
+61 8 9221 1860