[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problem is something with MULTILIB (was Re: Something screwed up in PROJECT_ROOT or PROJECT_TOPdir)



OK, in the light of morning I made a little more progress, and I think I'm close.

Looking at the generated Makefiles I see where the directory is being dropped. I located the place where I wound up with "///" for the install of the headers that are in the wrong place:

/usr/bin/install -c -m 644 ../../../../../../tools/rtems-4.7/c/src/../../cpukit/backward/asm.h ./..///../../../mvme5500/lib/include/asm.h

and when I look at the Makefile I see that the missing piece is (I think) MULTIBUILDTOP:
PROJECT_INCLUDE = $(top_builddir)/../$(MULTIBUILDTOP)//../../../mvme5500/lib/include


Where MULTIBUILDTOP is nothing:
MULTIBUILDTOP =

So next I tried again with "--enable-multilib" in the RTEMS configuration.

The configuration is now:
configured by ../../tools/rtems-4.7/configure,
generated by GNU Autoconf 2.59,with options
\"'--target=powerpc-rtems'
'--prefix=/opt/rtems-4.7'
'--enable-posix'
'--enable-networking'
'--enable-cxx'
'--enable-rtems-debug'
'--disable-itron'
'--enable-multilib'
'--enable-maintainer-mode'
'--enable-rtemsbsp=mvme5500'
'target_alias=powerpc-rtems'\"

but now it fails with an "Unsupported CPU Model":

gmake[4]: Entering directory `/usr/home/dufault/work/rtems_builder/powerpc-rtems/rtems-4.7/powerpc- rtems/cpukit/score'true DO=all multi-doMaking all in .gmake[5]: Entering directory `/usr/home/dufault/work/rtems_builder/powerpc-rtems/rtems-4.7/powerpc- rtems/cpukit/score'if gcc34 --pipe -DHAVE_CONFIG_H -I.. -I../../lib/include -D__RTEMS_INSIDE__ -Wall -fasm -g -O2 -MT src/libscore_a-apiext.o -MD -MP -MF "src/.deps/libscore_a-apiext.Tpo" -c -o src/libscore_a-apiext.o `test -f 'src/apiext.c' || echo '../../../../../tools/rtems-4.7/cpukit/score/'`src/apiext.c; \then mv -f "src/.deps/libscore_a-apiext.Tpo" "src/.deps/libscore_a-apiext.Po"; else rm -f "src/.deps/libscore_a-apiext.Tpo"; exit 1; fi
In file included from ../../lib/include/rtems/score/cpu.h:12,
from ../../lib/include/rtems/system.h:144,
from ../../../../../tools/rtems-4.7/cpukit/score/src/apiext.c:19:../../lib/ include/rtems/score/powerpc.h:222:2: #error "Unsupported CPU Model"
gmake[5]: *** [src/libscore_a-apiext.o] Error 1
However, there are two probably related problems now:



1. The CPU model is no longer on the command line; 2. It's using the host compiler.

I tried again adding "--with-cpu=7450" to the configuration (removing the build directory, of course) but it fails identically.

I'll try again specifically setting CC_FOR_TARGET and CXX_FOR_TARGET but maybe someone knows what I'm doing wrong now.

Peter

Peter Dufault
HD Associates, Inc.