[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error configuring RTEMS 4.7



I'm trying to build the MVME5500 BSP in powerpc using 4.7, but I'm not having much luck.
I'm using the same set of tools in the past:


autoconf259
autoheader259
autom4te259
automake19
aclocal19
gm4 is GNU m4 1.4.1

but gm4 core dumps with a SIG11 during the bootstrap phase:

Memory bounds violation detected (SIGSEGV). Either a stack overflow
occurred, or there is a bug in /usr/local/bin/gm4. Check for possible infinite recursion.
autom4te259: /usr/local/bin/gm4 failed with exit status: 139


The system is:

FreeBSD shrimpy 4.11-RELEASE FreeBSD 4.11-RELEASE #4: Mon Feb 14 12:35:18 EST 2005 dufault@shrimpy:/usr/src/sys/compile/SHRIMPY i386

I've attached a shell script and its output. I've named them ".txt" to get past the mail filter.

Peter Dufault
HD Associates, Inc.

#!/bin/sh
# Invoke "bootstrap" and see it fail when
# m4 coredumps.
# I'm running this in:
# tools/rtems-4.7/c/src/lib/libbsp/powerpc/dmv177

# The system is:
# FreeBSD shrimpy 4.11-RELEASE FreeBSD 4.11-RELEASE #4: Mon Feb 14
# 12:35:18 EST 2005     dufault@shrimp:/usr/src/sys/compile/SHRIMPY i386

# Exit on errors:
set -e

# Set autotool versions:
AUTOCONF=autoconf259; export AUTOCONF
AUTOHEADER=autoheader259; export AUTOHEADER
AUTOM4TE=autom4te259; export AUTOM4TE
AUTOMAKE=automake19; export AUTOMAKE
ACLOCAL=aclocal19; export ACLOCAL

# Also, gm4 is GNU m4 1.4.1

# I added a "-e" to bootstrap to exit on errors,
# but I don't think the AUTOTOOLS report the error.
~/work/rtems_builder/tools/rtems-4.7/bootstrap -e -v 
.
aclocal19 -I ../../../../aclocal
/usr/X11R6/share/aclocal/xmms.m4:17: warning: underquoted definition of XMMS_TEST_VERSION
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/X11R6/share/aclocal/xmms.m4:62: warning: underquoted definition of AM_PATH_XMMS
/usr/X11R6/share/aclocal/oaf.m4:4: warning: underquoted definition of AM_PATH_OAF
/usr/X11R6/share/aclocal/libguppi.m4:11: warning: underquoted definition of AM_PATH_LIBGUPPI
/usr/X11R6/share/aclocal/libglade.m4:7: warning: underquoted definition of AM_PATH_LIBGLADE
/usr/X11R6/share/aclocal/libart.m4:11: warning: underquoted definition of AM_PATH_LIBART
/usr/X11R6/share/aclocal/imlib.m4:9: warning: underquoted definition of AM_PATH_IMLIB
/usr/X11R6/share/aclocal/imlib.m4:167: warning: underquoted definition of AM_PATH_GDK_IMLIB
/usr/X11R6/share/aclocal/gtkgl.m4:4: warning: underquoted definition of AM_PATH_GTKGL
/usr/X11R6/share/aclocal/gtk.m4:7: warning: underquoted definition of AM_PATH_GTK
/usr/X11R6/share/aclocal/gnucash.m4:9: warning: underquoted definition of AM_PATH_GNUCASH
/usr/X11R6/share/aclocal/gdk-pixbuf.m4:12: warning: underquoted definition of AM_PATH_GDK_PIXBUF
/usr/X11R6/share/aclocal/gconf-1.m4:4: warning: underquoted definition of AM_PATH_GCONF
/usr/X11R6/share/aclocal/gconf-1.m4:71: warning: underquoted definition of AM_GCONF_SOURCE
Memory bounds violation detected (SIGSEGV).  Either a stack overflow
occurred, or there is a bug in /usr/local/bin/gm4.  Check for possible infinite recursion.
autom4te259: /usr/local/bin/gm4 failed with exit status: 139
autoheader259: error: AC_CONFIG_HEADERS not found in configure.ac
autoheader259
automake19: reading autoconf259 --trace=LT_SUPPORTED_TAG:\$f:\$l::\$n::\${::}% --trace=AM_CONDITIONAL:\$f:\$l::\$n::\${::}% --trace=m4_include:\$f:\$l::\$n::\${::}% --trace=AC_CONFIG_AUX_DIR:\$f:\$l::\$n::\${::}% --trace=AC_CANONICAL_HOST:\$f:\$l::\$n::\${::}% --trace=AM_AUTOMAKE_VERSION:\$f:\$l::\$n::\${::}% --trace=AC_LIBSOURCE:\$f:\$l::\$n::\${::}% --trace=AC_CONFIG_FILES:\$f:\$l::\$n::\${::}% --trace=AC_CANONICAL_TARGET:\$f:\$l::\$n::\${::}% --trace=_LT_AC_TAGCONFIG:\$f:\$l::\$n::\${::}% --trace=AC_CONFIG_HEADERS:\$f:\$l::\$n::\${::}% --trace=AC_SUBST:\$f:\$l::\$n::\${::}% --trace=AM_ENABLE_MULTILIB:\$f:\$l::\$n::\${::}% --trace=sinclude:\$f:\$l::\$n::\${::}% --trace=m4_sinclude:\$f:\$l::\$n::\${::}% --trace=AC_INIT:\$f:\$l::\$n::\${::}% --trace=AM_INIT_AUTOMAKE:\$f:\$l::\$n::\${::}% --trace=AC_CONFIG_LINKS:\$f:\$l::\$n::\${::}% --trace=AM_MAINTAINER_MODE:\$f:\$l::\$n::\${::}% --trace=AC_CANONICAL_BUILD:\$f:\$l::\$n::\${::}% --trace=AM_PROG_CC_C_O:\$f:\$l::\$n::\${::}% --trace=AM_GNU_GETTEXT:\$f:\$l::\$n::\${::}%
configure.ac: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.ac: You should verify that configure.ac invokes AM_INIT_AUTOMAKE,
configure.ac: that aclocal.m4 is present in the top-level directory,
configure.ac: and that aclocal.m4 was recently regenerated (using aclocal).
automake19: reading /usr/local/share/automake19/am/header-vars.am
automake19: reading Makefile.am
automake19: reading ../../../../automake/compile.am
../../../../automake/compile.am:7: RTEMS_USE_GCC does not appear in AM_CONDITIONAL
Makefile.am:7:   `../../../../automake/compile.am' included from here
../../../../automake/compile.am:14: RTEMS_USE_GCC does not appear in AM_CONDITIONAL
Makefile.am:7:   `../../../../automake/compile.am' included from here
automake19: reading ../../bsp.am
Makefile.am:65: HAS_NETWORKING does not appear in AM_CONDITIONAL
Makefile.am:79: HAS_NETWORKING does not appear in AM_CONDITIONAL
automake19: reading ../../../../automake/subdirs.am
automake19: reading ../../../../automake/local.am
Makefile.am: required file `./NEWS' not found
Makefile.am: required file `./AUTHORS' not found
automake19: reading /usr/local/share/automake19/am/configure.am
automake19: reading /usr/local/share/automake19/am/libs.am
Makefile.am:73: library used but `RANLIB' is undefined
Makefile.am:73: 
Makefile.am:73: The usual way to define `RANLIB' is to add `AC_PROG_RANLIB'
Makefile.am:73: to `configure.ac' and run `autoconf' again.
automake19: reading /usr/local/share/automake19/am/library.am
automake19: reading /usr/local/share/automake19/am/progs.am
automake19: reading /usr/local/share/automake19/am/program.am
automake19: reading /usr/local/share/automake19/am/compile.am
automake19: reading /usr/local/share/automake19/am/depend.am
automake19: reading /usr/local/share/automake19/am/depend2.am
automake19: Sources ending in .c become .o
/usr/local/share/automake19/am/depend2.am: am__fastdepCC does not appear in AM_CONDITIONAL
/usr/local/share/automake19/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
automake19: Sources ending in .c become .obj
automake19: reading /usr/local/share/automake19/am/lang-compile.am
automake19: reading /usr/local/share/automake19/am/texinfos.am
Makefile.am:27: `project_lib_DATA' is used but `project_libdir' is undefined
Makefile.am:10: `dist_project_lib_DATA' is used but `project_libdir' is undefined
automake19: reading /usr/local/share/automake19/am/header.am
automake19: reading /usr/local/share/automake19/am/data.am
automake19: reading /usr/local/share/automake19/am/inst-vars.am
automake19: reading /usr/local/share/automake19/am/tags.am
automake19: reading /usr/local/share/automake19/am/distdir.am
automake19: reading /usr/local/share/automake19/am/footer.am
automake19: reading /usr/local/share/automake19/am/install.am
automake19: reading /usr/local/share/automake19/am/clean.am
automake19: not writing ./Makefile.in because of earlier errors