[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IP address woes



I am having trouble getting my RTEMS UDP to work properly with my RTEMS 
project and my Mac.

The way it works is that I send a broadcast message to find my RTEMS 
device by sending UDP to 192.168.0.255
My device always gets it and attempts to send a response to the exact IP 
address that sent it. Often, it says that couldn't send socket - host is 
down. Then I unplug and replug my mac and it can then send the response, 
and my Mac receives it, and correctly determines the exact IP address of 
my device. Then, if I try to send to the exact IP address, the Mac says 
that the host is down. If I try to ping from the mac, I get a host is 
down message.
If I go to a Windows machine connected on the network, I can ping both 
the Mac and the RTEMS. In fact, I don't have any problems at all using 
Windows.

I changed the chips on my device, and the error stayed with the chip - 
i.e. the Mac worked with one and not the other. Then all of a sudden, it 
swapped about the one that did not work worked, and vice versa. I know I 
did not make a mistake on this part because I gave the response a unique 
name that was configured in the the device as a text file.

Any idea's of what to look for?

-- 
Angelo Fraietta

PO Box 859
Hamilton NSW 2303

Home Page


http://www.users.bigpond.com/angelo_f/

There are those who seek knowledge for the sake of knowledge - that is CURIOSITY
There are those who seek knowledge to be known by others - that is VANITY
There are those who seek knowledge in order to serve - that is LOVE
    Bernard of Clairvaux (1090 - 1153)