[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: rtems-ss-20030128



Yes but my board have yet the shmsupp directory... :-((
My Makefile.am have shmsupp in the SUBDIRS list
and the configure.ac had the shmupp in the Makefile list...
I had run automake and autoconf.
Need I to run also aclocal?  
Francesco Poletti wrote:
> 
> Hy, I have tried to build rtems for my multi arm boards but I
receive
> an error.I have developed It starting from arm_bare_bsp like this
his
> name is arm_bare_bsp. I think that's a configure error:
> configure: configuring in arm_bare_bsp
> configure: running /bin/sh
>
'../../../../../../../../rtems-ss-20030128/c/src/lib/libbsp/arm/arm_bare_bsp/configure'
> --prefix=/home/poletti/rtemsmulti1
> '--prefix=/home/poletti/rtemsmulti1' '--host=arm-rtems'
> '--build=i686-pc-linux-gnu' '--target=arm-rtems'
'--enable-maintainer'
> '--enable-multiprocessing' '--enable-tests' '--enable-rtems-debug'
> '--with-target-subdir=arm-rtems'
> '--exec-prefix=/home/poletti/rtemsmulti1/arm-rtems'
> 'build_alias=i686-pc-linux-gnu' 'host_alias=arm-rtems'
> 'target_alias=arm-rtems' 'RTEMS_BSP=arm_bare_bsp'
> 'RTEMS_CPU_MODEL=arm7tdmi' 'RTEMS_BSP_FAMILY=arm_bare_bsp'
> 'CPU_CFLAGS=-mcpu=arm7tdmi' 'CFLAGS_OPTIMIZE_V=-O2'
> 'CFLAGS_DEBUG_V=-O1'
> '--srcdir=../../../../../../rtems-ss-20030128/c/src/lib/libbsp'
> '--cache-file=/dev/null'
>
'--srcdir=../../../../../../../rtems-ss-20030128/c/src/lib/libbsp/arm'
> --cache-file=/dev/null
>
--srcdir=../../../../../../../../rtems-ss-20030128/c/src/lib/libbsp/arm/arm_bare_bsp
> checking for gmake... gmake
> checking for RTEMS Version... ss-20021111
> checking build system type... i686-pc-linux-gnu
> checking host system type... arm-unknown-rtems
> checking target system type... arm-unknown-rtems
> checking rtems target cpu... arm
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether build environment is sane... yes
> checking for gawk... gawk
> checking whether gmake sets ${MAKE}... yes
> checking for arm-rtems-strip... arm-rtems-strip
> checking if cpu arm is supported... yes
> checking whether to enable maintainer-specific portions of
> Makefiles... no
> checking for RTEMS_BSP... arm_bare_bsp
> checking for make/custom/arm_bare_bsp.cfg... yes
> checking for RTEMS_CPU_MODEL...
> checking for RTEMS_BSP_FAMILY...
> checking for RTEMS_BSP_CFLAGS...
> checking for RTEMS_BSP_CFLAGS_OPTIMIZE_V...
> checking for RTEMS_BSP_CFLAGS_DEBUG_V...
> checking for RTEMS_BSP_CFLAGS_PROFILE_V...
> checking if wanting multiprocessing... yes
> checking whether BSP supports multiprocessing... no
> configure: error: multiprocessing requested but not supported
> configure: error: /bin/sh
>
'../../../../../../../../rtems-ss-20030128/c/src/lib/libbsp/arm/arm_bare_bsp/configure'
> failed for arm_bare_bsp
> configure: error: /bin/sh
>
'../../../../../../../rtems-ss-20030128/c/src/lib/libbsp/arm/configure'
> failed for arm
> configure: error: /bin/sh
> '../../../../../../rtems-ss-20030128/c/src/lib/libbsp/configure'
> failed for lib/libbsp
> gmake[2]: *** [arm_bare_bsp] Error 1
> gmake[2]: Leaving directory `/home/poletti/buildmulti1/arm-rtems/c'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory `/home/poletti/buildmulti1/arm-rtems/c'
> make: *** [all-recursive] Error 1

See $r/../aclocal/check-multiprocessing.m4 but right now the BSP
is assumed to not support multiprocesssing if it does not have an
shmsupp directory.

Ralf has thought this was a marginal solution for a while but we
don't have a better one.  

So add an shmsupp directory.  I know you are using the shmdr. :)

> Thanks to all which Can help me!
> Francesco