[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building Tools



I commenced building the tools, however, I have come into an error

I first had to make a soft link to binutils and gcc before moving to the 
build, otherwise the configure did not work  EG with gcc


        Configure, build and install the cross-compiler and libraries

       1. Create a directory in which the tools will be built and change
          to that directory.

rm -rf build
mkdir build
ln -s gcc-3.2.1 gcc
 cd build

       2. Configure the compiler and libraries.

../\gcc/configure --target=i386-rtems --prefix=/opt/rtems \
            --with-gnu-as --with-gnu-ld --with-newlib --verbose \
            --with-system-zlib --disable-nls \
            --enable-version-specific-runtime-libs \
            --enable-threads=rtems \
            --enable-languages=c,c++



The binutils worked fine, however, this was not the case with gcc.

During the build I got the following error

i386-rtems-ar  rc ./libgcc.a libgcc/./_muldi3.o libgcc/./_negdi2.o 
libgcc/./_lshrdi3.o libgcc/./_ashldi3.o libgcc/./_ashrdi3.o 
libgcc/./_ffsdi2.o libgcc/./_clz.o libgcc/./_cmpdi2.o 
libgcc/./_ucmpdi2.o libgcc/./_floatdidf.o libgcc/./_floatdisf.o 
libgcc/./_fixunsdfsi.o libgcc/./_fixunssfsi.o libgcc/./_fixunsdfdi.o 
libgcc/./_fixdfdi.o libgcc/./_fixunssfdi.o libgcc/./_fixsfdi.o 
libgcc/./_fixxfdi.o libgcc/./_fixunsxfdi.o libgcc/./_floatdixf.o 
libgcc/./_fixunsxfsi.o libgcc/./_fixtfdi.o libgcc/./_fixunstfdi.o 
libgcc/./_floatditf.o libgcc/./_clear_cache.o libgcc/./_trampoline.o 
libgcc/./__main.o libgcc/./_exit.o libgcc/./_absvsi2.o 
libgcc/./_absvdi2.o libgcc/./_addvsi3.o libgcc/./_addvdi3.o 
libgcc/./_subvsi3.o libgcc/./_subvdi3.o libgcc/./_mulvsi3.o 
libgcc/./_mulvdi3.o libgcc/./_negvsi2.o libgcc/./_negvdi2.o 
libgcc/./_ctors.o libgcc/./_divdi3.o libgcc/./_moddi3.o 
libgcc/./_udivdi3.o libgcc/./_umoddi3.o libgcc/./_udiv_w_sdiv.o 
libgcc/./_udivmoddi4.o libgcc/./_pack_sf.o libgcc/./_unpack_sf.o 
libgcc/./_addsub_sf.o libgcc/./_mul_sf.o libgcc/./_div_sf.o 
libgcc/./_fpcmp_parts_sf.o libgcc/./_compare_sf.o libgcc/./_eq_sf.o 
libgcc/./_ne_sf.o libgcc/./_gt_sf.o libgcc/./_ge_sf.o libgcc/./_lt_sf.o 
libgcc/./_le_sf.o libgcc/./_unord_sf.o libgcc/./_si_to_sf.o 
libgcc/./_sf_to_si.o libgcc/./_negate_sf.o libgcc/./_make_sf.o 
libgcc/./_sf_to_df.o libgcc/./_thenan_sf.o libgcc/./_sf_to_usi.o 
libgcc/./_usi_to_sf.o libgcc/./_pack_df.o libgcc/./_unpack_df.o 
libgcc/./_addsub_df.o libgcc/./_mul_df.o libgcc/./_div_df.o 
libgcc/./_fpcmp_parts_df.o libgcc/./_compare_df.o libgcc/./_eq_df.o 
libgcc/./_ne_df.o libgcc/./_gt_df.o libgcc/./_ge_df.o libgcc/./_lt_df.o 
libgcc/./_le_df.o libgcc/./_unord_df.o libgcc/./_si_to_df.o 
libgcc/./_df_to_si.o libgcc/./_negate_df.o libgcc/./_make_df.o 
libgcc/./_df_to_sf.o libgcc/./_thenan_df.o libgcc/./_df_to_usi.o 
libgcc/./_usi_to_df.o libgcc/./xp-bit.o libgcc/./unwind-dw2.o 
libgcc/./unwind-dw2-fde.o libgcc/./unwind-sjlj.o libgcc/./_eprintf.o 
libgcc/./_bb.o libgcc/./__gcc_bcmp.o
make[2]: i386-rtems-ar: Command not found
make[2]: *** [libgcc.a] Error 127
make[2]: Leaving directory `/opt/rtems/tools/build/gcc'
make[1]: *** [stmp-multilib] Error 2
make[1]: Leaving directory `/opt/rtems/tools/build/gcc'
make: *** [all-gcc] Error 2

I had a look through the previous configure and got this -- however I 
don't know whether it is relevant:

checking what nm to use... i386-rtems-nm
checking what objdump to use... i386-rtems-objdump
checking assembler alignment features... .p2align including maximum skip
checking assembler subsection support... ../../gcc/gcc/configure: 
i386-rtems-nm: command not found
../../gcc/gcc/configure: i386-rtems-nm: command not found
.subsection

I have attached my config script (I also tried it with removing the 
first \. i.e ../gcc instead of ../\gcc)

Any suggestions as to what I may be doing wrong

-- 
Angelo Fraietta

PO Box 859
Hamilton NSW 2303

Home Page


http://www.users.bigpond.com/angelo_f/

There are those who seek knowledge for the sake of knowledge - that is CURIOSITY
There are those who seek knowledge to be known by others - that is VANITY
There are those who seek knowledge in order to serve - that is LOVE
    Bernard of Clairvaux (1090 - 1153)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rtems.rtems.org/pipermail/rtems-users/attachments/20030226/7a0dfcfd/attachment.html 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: configtools
Url: http://rtems.rtems.org/pipermail/rtems-users/attachments/20030226/7a0dfcfd/attachment.pl