[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

4MByte limit in IMFS for each file?



Hello,

it's me again :-)

When I tried out my "fileio" sample, I hit a strange 4MByte 
limit when creating files in the IMFS. I was working on a 
PC386 target with 16MByte of memory (and most of it was always 
available on the heap). 


When I tried to create big files (like 8MB), the write call 
always failed (with a "no space left on device" error), 
directly after reaching a 4MByte file size boundary. 

This limit does not exist on the DOSFS, only when writing to 
the IMFS. I tried it out on a MBX8xx system (with 16MByte of 
RAM) and there I hit the limit also after 4MBytes.

I was browsing through the IMFS sources and did not find any 
reason for this limitation, and I did not yet run the test 
with a debugger.

Any hints on that issue?

wkr,
	Thomas.
--------------------------------------------
IMD Ingenieurbuero fuer Microcomputertechnik
Thomas Doerfler           Herbststrasse 8
D-82178 Puchheim          Germany
email:    Thomas.Doerfler at imd-systems.de
PGP public key available at: http://www.imd-
systems.de/pgp_keys.htm