[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

build & c tools



Salman wrote:
> I'm using standard gnu build programs
> (ie automake-1.72, autconf-2.57, aclocal-1.72)
> not the rtems ones (eg automake-rtems-automake-1.7.2)
> are they any different ??
> 
> furthermore, should the c-tools be updated if one wants to build the latest rtems snapshot?
> (i'm still using c-tools from rtems-4.5.0 decade)
> 

Hi Salman,

Yes!

You must _definitely_ use up-to date tools to build the newer snapshots
(and less obviously you must use out-of-date tools to build out-of-date
releases!)

Generally the best idea is to get the c-tools from the same release 
directory as the snap shot you are trying to build.


Best regards

Paul