[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RFC: new RTEMS IRQ requirements



Am Fre, 2003-02-21 um 00.11 schrieb Valette Eric:
> Joel Sherrill wrote:
> 
> > Speaking strictly from a historical perspective.  RTEMS used to make 
> > more use of m4 and it was a portability pain in the (*&^%#.  THe
> > situation may be better now but I somehow doubt it.  
m4 is a PITA portability-wise, at least when using it to the extend
autoconf does :(

Though I doubt we would be hit by the issues autoconf is facing (In most
cases exceeded buffers - Other problems, such as limitations of the m4
language will probably not hit), I would prefer if we could get away
without using it 

[I am inclined to think m4 would have been dead for quite a while if
autoconf and sendmail weren't using it;)]

> Sure, we should require gnu m4 to be installed not  system provided m4. 
> If memory serves I think ralph
Yes, Erik? ;)

>  already pointed out that gm4 should be 
> present for autoconf, automake anyway...
Right, autoconf requires gm4 and therefore probably already is available
in most U+ix-ish environments.

Ralf