[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Snapshot 20030128 broke my buildt



It appears to be very broken
I ran some of the samples with the following results:

    ticker ***********************
    - I get a message on the console that clock tick test is starting 
and then the machine reboots
   
    unlimited *************************
    I get the message
    TEST1: auto-extend disabled
    TEST1: creating task 'aa00', number = 0, ide = 0a010002, starting
   
    The application seems frozen now with a cursor blinking at one space 
after the comma on the last line

    paranoia *************************
    passes test

Could someone send me a copy of built examples of ticker and unlimited 
for a pc386dx build so I can eliminate or determine the problem is at my 
end?

Thanks



Angelo Fraietta wrote:

> My build is broken in that the application can no longer start.
> Is suspect that the problem may be in the static variable 
> initialisers, however, I am unsure.
>
> My device drivers are getting initialised (I can see this on the console)
> however I get an exception error
>
> exception 6 caught
>
> This ocurrs before a printf statement I placed at the start of r Init
>
> I also commented out all the code in the Init function and still got 
> the same error.
>
> I removed nearly all of my code and the application initialised
>
> Init is in a cpp module which is being executed
>
> I ahve also noticed that my app is about 25% larger than it used to be.
>
> Any suggestions?
>

-- 
Angelo Fraietta

PO Box 859
Hamilton NSW 2303

Home Page


http://www.users.bigpond.com/angelo_f/

There are those who seek knowledge for the sake of knowledge - that is CURIOSITY
There are those who seek knowledge to be known by others - that is VANITY
There are those who seek knowledge in order to serve - that is LOVE
    Bernard of Clairvaux (1090 - 1153)