[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error building RTEMS - Possible tools config error



I had an error attempting to build RTEMS. I did the following (from 
Eric' page)

   1.
      ../rtems-ss-20030128/configure --target=i386-rtems
      --prefix=/opt/rtems \
         --enable-cxx --enable-rdbg --disable-tests --enable-networking \
         --enable-posix --enable-itron

      <snip>
   2. Build and install RTEMS for one or more board-support packages
      using the target architecture configured in the previous step. The
      pc386 board support package which works on standard PC hardware
      would be specified as:

make RTEMS_BSP=pc386

however I got an error that
    i386-rtems-g++
was not present. I looked in /opt/rtems/bin and it was not there so I 
made a soft link from i386-rtems-cpp to i386-rtems-g++, i.e.

    ln -s i386-rtems-cpp i386-rtems-g++

The build seems to be taking place just fine now.

Is it possible that there is a problem in building of the RTEMS toolset 
or have I done something wrong?

-- 
Angelo Fraietta

PO Box 859
Hamilton NSW 2303

Home Page


http://www.users.bigpond.com/angelo_f/

There are those who seek knowledge for the sake of knowledge - that is CURIOSITY
There are those who seek knowledge to be known by others - that is VANITY
There are those who seek knowledge in order to serve - that is LOVE
    Bernard of Clairvaux (1090 - 1153)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rtems.rtems.org/pipermail/rtems-users/attachments/20030226/b72a3b93/attachment.html