[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

compile binutils-2.9.1



Thank you for your help.

    I follow your advice and get binutils-2.9.1 compiled. Now I encounted
another question .
I try to build egcs1.1b ( since I can't got egcs1.1.2-rtems-diff patch ) . I
use follow command
/tools/egcs-1.1b/configure --verbose --target=powerpc-rtems \
              --prefix=/gcc-powerpc --with-gnu-as --with-gnu-ld \
              --with-newlib
I get the result :

for name in _muldi3 _divdi3 _moddi3 _udivdi3 _umoddi3 _negdi2 _lshrdi3
_ashldi3
_ashrdi3 _ffsdi2 _udiv_w_sdiv _udivmoddi4 _cmpdi2 _ucmpdi2 _floatdidf
_floatdisf
 _fixunsdfsi _fixunssfsi _fixunsdfdi _fixdfdi _fixunssfdi _fixsfdi _fixxfdi
_fix
unsxfdi _floatdixf _fixunsxfsi _fixtfdi _fixunstfdi _floatditf __gcc_bcmp
_varar
gs __dummy _eprintf _bb _shtab _clear_cache _trampoline __main _exit _ctors
_pur
e; \
do \
  echo ${name}; \
  //h/rtems/build/egcs/gcc/xgcc -B//h/rtems/build/egcs/gcc/ -O2
-DCROSS_COMPILE
 -DIN_GCC    -g -O2 -I./include   -g1  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED
-Di
nhibit_libc   -mrelocatable-lib -mno-eabi -mstrict-align -I.
-I/tools/egcs-1.1b/
gcc -I/tools/egcs-1.1b/gcc/config -c -DL${name} \
      /tools/egcs-1.1b/gcc/libgcc2.c -o ${name}.o; \
  if [ $? -eq 0 ] ; then true; else exit 1; fi; \
  powerpc-rtems-ar rc tmplibgcc2.a ${name}.o; \
  rm -f ${name}.o; \
done
_muldi3
as: unrecognized option `-ppc'
make[3]: *** [libgcc2.a] Error 1
make[2]: *** [stmp-multilib-sub] Error 2
make[1]: *** [stmp-multilib] Error 1
make: *** [cross] Error 2

Rosimildo da Silva wrote:

> "Shen,HuiJie" wrote:
> >
> > Hello :
> >    I try to build cross compiler of mpc on NT server.
> >    I installed cywin and do as instruction of RTEMS 19991117 On-Line
> > Library.
> > after , it seems OK after doing
> >
> > /source/binutils-2.9.1/configure --verbose --target=powerpc-rtems \
> >               --prefix=/gcc-powerpc-rtems --with-gnu-as --with-gnu-ld
> >
>
> Compiling the toolset with CygWin is not easy !!!. :-)
>
> You did not mention which version of the tools you are using.
> Stating that, might give us some clues.
>
> I've got the impression from you post that you're using CygWin B19.
> This version is very bug. I would recommend an upgrate to B20.1 to start
> with.
>
> Rosimildo.