[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IEEE and m68k-rtems-objcopy



   From: "Andrew Bythell" <abythell at nortelnetworks.com>
   Date: Fri, 23 Jul 1999 16:35:28 -0400

   I am using binutils 2-9.1 with the corresponding patch from the OARcorp ftp
   site.   To make an IEEE file called test.ieee from the m68k-rtems-gcc
   generated test.exe, I run "m68k-rtems-objcopy -O ieee test.exe test.ieee".
   It completes without complaining.  I've used m68k-rtems-objcopy to generate
   S-records, and that worked well.

   I'm using the X-Ray tools for flash programming/debugging.  When I try to
   load test.ieee, it spits out, "Unable to identify absolute file type".  I
   tried to reverse the process:  I compiled an IEEE file using MRI's
   compiler/linker, then tried to 'objcopy' it from IEEE to S-Record.  Objcopy
   said, "File Format not recognized"

   Has anyone successfully used objcopy generated IEEE files with other tools?

Yes, I have.  In fact, I've used them with X-Ray, and I've used
objcopy and objdump on the output of the MRI compiler.

I don't know what the error you are getting from X-Ray means.  The
error from objcopy means that ieee_object_p is not recognizing the
file.  Try setting a breakpoint there to see why it is failing.

You may want to check the development sources at
    http://sourceware.cygnus.com/binutils
Take a look at bfd/ieee.c.  I have a vague recollection that there was
something broken about m68k IEEE support around the 2.9.1 release.  I
thought it got fixed in 2.9.1, but I may be misremembering.

Ian