[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IEEE and m68k-rtems-objcopy



I am using binutils 2-9.1 with the corresponding patch from the OARcorp ftp
site.   To make an IEEE file called test.ieee from the m68k-rtems-gcc
generated test.exe, I run "m68k-rtems-objcopy -O ieee test.exe test.ieee".
It completes without complaining.  I've used m68k-rtems-objcopy to generate
S-records, and that worked well.

I'm using the X-Ray tools for flash programming/debugging.  When I try to
load test.ieee, it spits out, "Unable to identify absolute file type".  I
tried to reverse the process:  I compiled an IEEE file using MRI's
compiler/linker, then tried to 'objcopy' it from IEEE to S-Record.  Objcopy
said, "File Format not recognized"

Has anyone successfully used objcopy generated IEEE files with other tools?


Andrew Bythell  System Design For Test
Nortel Networks  Microelectronics Group
tel.613.765-6930             esn.39.56930

> -----Original Message-----
> From:	Ian Lance Taylor [SMTP:ian at zembu.com]
> Sent:	Friday, July 23, 1999 4:08 PM
> To:	Bythell, Andrew [CAR:5T45:EXCH]
> Cc:	rtems-list at oarcorp.com
> Subject:	Re: IEEE and m68k-rtems-objcopy
> 
> 
> 
>    From: "Andrew Bythell" <abythell at nortelnetworks.com>
>    Date: Fri, 23 Jul 1999 15:05:12 -0400
> 
>    I use a tool to program flash parts and debug via BDM.  It accepts
> IEEE695
>    objects.  RTEMS patches Binutils to add IEEE-target support to
>    m68k-rtems-objcopy.   Therefore, by using objcopy, one should be able
> to
>    generate IEEE objects for use with my tool.  Fine.
> 
>    The problem is that my flash programmer fails to recognize the file as
> IEEE.
>    This leads me to wonder:  are there other IEEE standards for objects,
> and if
>    so, what kind does m68k-rtems-objcopy produce?  Is it possible to patch
>    objcopy to make IEEE695 objects?
> 
> There is only one IEEE object file format, which is IEEE-695.  That is
> the format of the files that objcopy generates.
> 
> Does your flash programmer provide any information as to why the
> IEEE-695 file is not recognized?  Which version of the GNU binutils
> are you using?  What operation are you doing to produce a IEEE-695
> file?  Do you have any other tools that expect IEEE-695 files as
> input, and what do they say?
> 
> Ian