[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

troubles installing rtems - the sequel part 4




On Wed, 4 Mar 1998, Geoffroy Montel wrote:

> - when doing make all: Dr Watson reports a "conftest.exe" error...

I am not even sure what conftest.exe is.

> - the install-if-change is not really solved
> - about the last error, the gcc abort.

Weird but probably all related.

>   It's quite odd too. I went into the subdirectory and executed the
>   full command line, and it worked. Just two warnings about the
>   interrupt stack

Could it be a limit on the number of processes?  The RTEMS make scheme
descends pretty deep and than cranks off a number of processes via make
and shells scripts.

The warning is OK since we do not yet (RSN thanks to Chris Johns) have
a dedicated SW interrupt stack on some m68k models.

> - then I continued the make all, and a similar thing occured:
> 
> /gcc-m68k-rtems/bin/m68k-rtems-gcc --pipe -Dmcpu32 -D__mcpu32__ 
> -m68020 -mnobit
> field -msoft-float -Wall -ansi -fasm -g -B/rtems-build/gen68360/lib/
> -specs bsp_
> specs -qrtems -I/rtems-build/gen68360/lib/include/ka9q  -O4
> -fomit-frame-pointer
>      -c -o o-gen68360/apiext.o
> ../../../../../rtems-980219/c/src/exec/score/src/
> apiext.c
> make[5]: *** [o-gen68360/apiext.o] Aborted

It looks to be 5 levels done in the make tree.  CygWin could be blowing up
with toomany processes or something similar.

--joel